The system of ESR router CLI commands is divided into hierarchic levels (sections).

Global mode

Top level of the command hierarchy is shown in the table 2.

Table 2 – Command modes hierarchy (top level)

Level

Entry command

Prompt line view

Exit command

Root mode (ROOT)


esr>

esr#

exit

end

Configuration mode (CONFIG)

configure

esr(config)#

Device debugging mode (DEBUG)

debug

esr(debug)#

 

Figure 1 – Top level of command mode hierarchy

In root command mode (ROOT) you can perform the following:

– operation with configuration files:

  • application;
  • confirmation;
  • reset;
  • saving;
  • undo pending changes;
  • revert to the confirmed configuration;

– router reboot;

– monitoring and the current device configuration displaying.

From the root mode (ROOT), proceeding to the following sections is performed:

– device configuration mode (CONFIG);

– device debugging mode (DEBUG).

Router configuration

ESR router configuration is performed in CONFIG mode The mode is available from the root mode (ROOT). Switching to the configuration mode is performed only in a privileged one.

To switch from the root mode (ROOT), you should run the following commands:

esr> enable
esr# configure
esr(config)#
CODE

In ESR router configuration mode the following functions are performed:

– system timer management;

– system log management;

– remote access configuration;

– QoS configuration;

– Spanning Tree configuration;

– VLAN configuration;

– static routes configuration;

– routing protocol precedence configuration;

– switching to the function configuration modes, the description is shown in the table 3.

Table 3 – Command modes for router management

Level

Entry command1

Prompt line view

Previous level

Global parameters configuration

(CONFIG)

configure

esr(config)#

ROOT

GigabitEthernet interface configuration
(CONFIG-GI)

interface gigabitethernet <PORT>

esr(config-if-gi)#

CONFIG

TengigabitEthernet interface configuration
(CONFIG-TE)

interface tengigabitethernet <PORT>

esr(config-if-te)#

CONFIG

Channel aggregation groups configuration

(CONFIG-PORT-CHANNEL)

interface port-channel <CH>

esr(config-port-channel)#

CONFIG

Subinterface configuration

(CONFIG-SUBIF)

interface gigabitethernet <PORT>.<VLAN> or

interface tengigabitethernet <PORT>.<VLAN> or

interface port-channel <CH>.<VLAN>

esr(config-subif)#

CONFIG

Subinterface configuration

(CONFIG-QINQ-IF)

interface gigabitethernet <PORT>.<VLAN>.<VLAN> or

interface tengigabitethernet <PORT>.<VLAN>.<VLAN> or

interface port-channel <CH>.<VLAN>.<VLAN>

esr(config-qinq-if)#

CONFIG

Serial interface configuration 2

(CONFIG-SERIAL)

interface serial <PORT>

esr(config-serial)#

CONFIG

Virtual interfaces configuration

(CONFIG-LOOPBACK)

interface loopback <PORT>

esr(config-loopback)#

CONFIG

E1 interface configuration

(CONFIG-E1)

interface e1 <PORT>

esr(config-e1)#

CONFIG

E1 channels aggregation group configuration
(CONFIG-MULTILINK)

interface multilink <PORT>

esr(config-multilink)#

CONFIG

FXO port configuration

(CONFIG-VOICE-PORT-FXO)

interface voice-port <NUM>

esr(config-voice-port-fxo)#

CONFIG

FXS port configuration

(CONFIG-VOICE-PORT-FXS)

interface voice-port <NUM>

esr(config-voice-port-fxs)#

CONFIG

VTI configuration

(CONFIG-VTI)

tunnel vti <VTI>

esr(config-vti)#

CONFIG

Serial interface configuration

(CONFIG-LINE-AUX)

line aux <NUM>

esr(config-line-aux)#

CONFIG

L2TPv3 tunnel configuration

(CONFIG-L2TPV3)

tunnel l2tpv3 <L2TPV3>

esr(config-l2tpv3)#

CONFIG

GRE tunnel configuration

(CONFIG-GRE)

tunnel gre <GRE>

esr(config-gre)#

CONFIG

SoftGRE tunnels configuration

(CONFIG-SOFTGRE)

tunnel softgre <SOFTGRE>

esr(config-softgre)#

CONFIG

Logical tunnels configuration

(CONFIG-LT)

tunnel lt <LT>

esr(config-lt)#

CONFIG

Configuration of sub interface on L2 tunnel

(CONFIG-SUBTUNNEL)

tunnel softgre <GRE>.<VLAN>

esr(config-subtunnel)#

CONFIG

IPv4-over-IPv4 tunnel configuration

(CONFIG-IP4IP4)

tunnel ip4ip4 <IP4IP4>

esr(config-ip4ip4)#

CONFIG

Network bridges configuration

(CONFIG-BRIDGE)

bridge <BRIDGE>

esr(config-bridge)#

CONFIG

VLAN Configuration

(CONFIG-VLAN)

vlan <VLAN>

esr(config-vlan)#

CONFIG

Network policy configuration for VLAN specification by LLDPDU messages of a client

(CONFIG-NET-POLICY)

network-policy <NAME>

esr(config-net-policy)

CONFIG

DHCP server's address pool configuration

(CONFIG-DHCP-SERVER)

ip dhcp-server pool <NAME>

esr(config-dhcp-server)#

CONFIG

DHCP option 60 configuration

(CONFIG-DHCP-VENDOR-ID)

ip dhcp-server vendor-class-id <NAME>

esr(config-dhcp-vendor-id)#

CONFIG

DHCP server's address pool configuration

(CONFIG-IPV6-DHCP-SERVER)

ipv6 dhcp-server pool <NAME>

esr(config-ipv6-dhcp-server)#

CONFIG

DHCP option 60 configuration

(CONFIG-IPV6-DHCP-VENDOR-ID)

ipv6 dhcp-server vendor-class-id <NAME>

esr(config-dhcp-vendor-id)#

CONFIG

Application profile configuration

(CONFIG-OBJECT-GROUP-APPLICATION)

object-group application <NAME>

esr(config-object-group-application)#

CONFIG

IP address profile configuration

(CONFIG-OBJECT-GROUP-NETWORK)

object-group network <NAME>

esr(config-object-group-network)#

CONFIG

IP address and TCP/UDP
port bindings profile configuration

(CONFIG-OBJECT-GROUP-ADDRESS-PORT)

object-group address-port <NAME>

esr(config-object-group-address-port)#

CONFIG

TCP/UDP ports profile configuration

(CONFIG-OBJECT-GROUP-SERVICE)

object-group service <NAME>

esr(config-object-group-service)#

CONFIG

URL profile configuration

(CONFIG-OBJECT-GROUP-URL)

object-group url <NAME>

esr(config-object-group-url)#

CONFIG

Configuration of the content filtering category provider

(CONFIG-OBJECT-GROUP-CONTENT-FILTER)

object-group content-filter <NAME>

esr(config-object-group-content-filter)#

CONFIG

Configuration of the content filtering category profile from the Kaspersky Laboratory vendor

(CONFIG-OBJECT-GROUP-CF-KASPERSKY)

vendor <VENDOR>

esr(config-object-group-cf-kaspersky)#

CONFIG-OBJECT-GROUP-CONTENT-FILTER

Configuration of the mail domain profile and mailbox addresses

(CONFIG-OBJECT-GROUP-MAIL)

object-group email <NAME>

esr(config-object-group-email)#

CONFIG

XAUTH profile configuration

(CONFIG-ACCESS-PROFILE)

access profile <NAME>

esr(config-access-profile)#

CONFIG

IP address pool configuration

(CONFIG-POOL)

address-assignment pool <NAME>

esr(config-pool)#

CONFIG

IKE protocol gateway configuration

(CONFIG-IKE-GATEWAY)

security ike gateway <NAME>

esr(config-ike-gw)#

CONFIG

IKE protocol policy configuration

(CONFIG-IKE-POLICY)

security ike policy <NAME>

esr(config-ike-policy)#

CONFIG

IKE protocol profile configuration

(CONFIG-IKE-PROPOSAL)

security ike proposal <NAME>

esr(config-ike-proposal)#

CONFIG

IPsec protocol set policy configuration

(CONFIG-IPSEC-POLICY)

security ipsec policy <NAME>

esr(config-ipsec-policy)#

CONFIG

IPsec protocol set profile configuration

(CONFIG-IPSEC-PROPOSAL)

security ipsec proposal <NAME>

esr(config-ipsec-proposal)#

CONFIG

IPsec-based VPN configuration

(CONFIG-IPSEC-VPN)

security ipsec vpn <NAME>

esr(config-ipsec-vpn)#

CONFIG

Access control list configuration

(CONFIG-ACL)

ip access-list extended <NAME>

esr(config-acl)#

CONFIG

Access control list rule configuration

(CONFIG-ACL-RULE)

rule <ORDER>

esr(config-acl-rule)#

CONFIG-ACL

Security zone configuration

(CONFIG-ZONE)

security zone <NAME>

esr(config-zone)#

CONFIG

Rule group configuration for security zone pairs

(CONFIG-ZONE-PAIR)

security zone-pair <FROM> <TO>

esr(config-zone-pair)#

CONFIG

Rule configuration for security zone pairs

(CONFIG-ZONE-PAIR-RULE)

rule <ORDER>

esr(config-zone-rule)#

CONFIG-ZONE-PAIR

Configuration of destination address translation service

(CONFIG-DNAT)

nat destination

esr(config-dnat)#

CONFIG

IP addresses pool and TCP/UDP ports for DNAT configuration

(CONFIG-DNAT-POOL)

pool <NAME>

esr(config-dnat-pool)#

CONFIG-DNAT

DNAT rule group configuration

(CONFIG-DNAT-RULESET)

ruleset <NAME>

esr(config-dnat-ruleset)#

CONFIG-DNAT

DNAT rule configuration

(CONFIG-DNAT-RULE)

rule <ORDER>

esr(config-dnat-rule)#

CONFIG-DNAT-RULESET

Source address translation service configuration

(CONFIG-SNAT)

nat source

esr(config-snat)#

CONFIG

Configuring IP addresses pool and TCP/UDP ports for SNAT

(CONFIG-SNAT-POOL)

pool <NAME>

esr(config-snat-pool)#

CONFIG-SNAT

SNAT rule group configuration

(CONFIG-SNAT-RULESET)

ruleset <NAME>

esr(config-snat-ruleset)#

CONFIG-SNAT

SNAT rule configuration

(CONFIG-SNAT-RULE)

rule <ORDER>

 esr(config-snat-rule)#

CONFIG-SNAT-RULESET

System users configuration

(CONFIG-USER)

username <NAME>

esr(config-user)#

CONFIG

Local console configuration

(CONFIG-LINE-CONSOLE)

line console

esr(config-line-console)#

CONFIG

Remote console configuration

(CONFIG-LINE-TELNET)

line telnet

esr(config-line-telnet)#

CONFIG

Remote protected console configuration

(CONFIG-LINE-SSH)

line ssh

esr(config-line-ssh)#

CONFIG

TACACS server configuration

(CONFIG-TACACS-SERVER)

tacacs-server host <ADDR>

esr(config-tacacs-server)#

CONFIG

RADIUS server configuration

(CONFIG-RADIUS-SERVER)

radius-server host <ADDR>

esr(config-radius-server)#

CONFIG

RADIUS server profile configuration

(CONFIG-RADIUS-SERVER-PROFILE)

aaa radius-profile <NAME>

esr(config-aaa-radius-profile)#

CONFIG

DAS server configuration

(CONFIG-DAS-SERVER)

das-server <NAME>

esr(config-das-server)#

CONFIG

DAS server profile configuration

(CONFIG-DAS-SERVER-PROFILE)

aaa das-profile <NAME>

esr(config-aaa-das-profile)#

CONFIG

LDAP server configuration

(CONFIG-LDAP-SERVER)

ldap-server host <ADDR>

esr(config-ldap-server)#

CONFIG

Configuration of remote access server via PPTP

(CONFIG-PPTP-SERVER)

remote-access pptp <NAME>

esr(config-pptp-server)#

CONFIG

Configuration of remote user access via PPTP

(CONFIG-PPTP-USER)

username <NAME>

esr(config-pptp-user)#

CONFIG-PPTP

Configuration of remote access server via L2TP

(CONFIG-L2TP-SERVER)

remote-access l2tp <NAME>

esr(config-l2tp-server)#

CONFIG

Configuration of remote user access via L2TP

(CONFIG-L2TP-USER)

username <NAME>

esr(config-l2tp-user)#

CONFIG-L2TP-SERVER

Configuration of remote access server via OpenVPN

(CONFIG-OPENVPN-SERVER)

remote-access openvpn <NAME>

esr(config-openvpn-server)#

CONFIG

Configuration of remote user access via L2TP

(CONFIG-OPENVPN-USER)

username <NAME>

esr(config-openvpn-user)#

CONFIG-OPENVPN-SERVER

Configuration of remote access client via PPTP

(CONFIG-PPTP)

tunnel pptp <PPTP-ID>

esr(config-pptp)#

CONFIG

Configuration of remote access client via PPPoE

(CONFIG-PPPOE)

tunnel pppoe <PPPOE-ID>

esr(config-pppoe)#

CONFIG

Configuration of remote connection client via L2TP

(CONFIG-L2TP)

tunnel l2tp <L2TP-ID>

esr(config-l2tp)#

CONFIG

Configuration of remote connection client via OpenVPN

(CONFIG-OPENVPN)

tunnel openvpn <OPENVPN-ID>

esr(config-openvpn)#

CONFIG

SNMP user configuration

(CONFIG-SNMP-USER)

snmp-server <NAME>

esr(config-snmp-user)#

CONFIG

NTP server or peer configuration

(CONFIG-NTP)

ntp server <ADDR>

ntp peer <ADDR>

esr(config-ntp)#

CONFIG

BGP process configuration

(CONFIG-BGP)

router bgp <AS>

esr(config-bgp)#

CONFIG

Configuration of BGP process in vrf

(CONFIG-BGP-VRF)

vrf <VRF>

esr(config-bgp-vrf)#

CONFIG-BGP

Configuration of BGP process IPv4/IPv6 addressing

(CONFIG-BGP-FAMILY)

address-family { ipv4 | ipv6 } unicast

esr(config-bgp-af)#

CONFIG-BGP

Configuration of BGP process IPv4/IPv6 addressing in vrf

(CONFIG-BGP-VRF-FAMILY)

address-family { ipv4 | ipv6 } unicast

esr(config-bgp-vrf-af)#

CONFIG-BGP-VRF

Configuration of BGP neighbor grouping

(CONFIG-BGP-GROUP)

peer-group <NAME>

esr(config-bgp-group)#

CONFIG-BGP

Configuration of BGP neighbor grouping in vrf

(CONFIG-BGP-VRF-GROUP)

peer-group <NAME>

esr(config-bgp-vrf-group)#

CONFIG-BGP-VRF

BGP process neighbor configuration

(CONFIG-BGP-NEIGHBOR)

neighbor { <ADDR> | <IPV6-ADDR> }

esr(config-bgp-neighbor)#

CONFIG-BGP

Configuration of BGP process neighbor in vrf

(CONFIG-BGP-VRF-NEIGHBOR)

neighbor { <ADDR> | <IPV6-ADDR> }

esr(config-bgp-vrf-neighbor)#

CONFIG-BGP-VRF

Configuration of BGP neighbor IPv4/IPv6 addressing

(CONFIG-BGP-NEIGHBOR-FAMILY)

address-family { ipv4 | ipv6 | vpnv4 } unicast

esr(config-bgp-neighbor-af)#

CONFIG-BGP-NEIGHBOR

Configuration of BGP neighbor IPv4/IPv6 addressing in vrf

(CONFIG-BGP-NEIGHBOR-FAMILY)

address-family { ipv4 | ipv6 | vpnv4 } unicast

esr(config-bgp-neighbor-af-vrf)#

CONFIG-BGP-VRF-NEIGHBOR

Subnet list configuration

(CONFIG-PL)

ip prefix-list <NAME>

esr(config-pl)#

CONFIG

Subnet list configuration

(CONFIG-IPV6-PL)

ipv6 prefix-list <NAME>

esr(config-ipv6-pl)#

CONFIG

Route map configuration

(CONFIG-ROUTE-MAP)

route-map <NAME>

esr(config-route-map)#

CONFIG

Route map rule configuration

(CONFIG-ROUTE-MAP-RULE)

rule <ORDER>

esr(config-route-map-rule)#

CONFIG-ROUTE-MAP

RIP configuration

(CONFIG-RIP)

router rip

esr(config-rip)#

CONFIG

RIPNG configuration

(CONFIG-RIPNG)

ipv6 router rip

esr(config-ripng)#

CONFIG

IS-IS process configuration

(CONFIG-ISIS)

router isis <ID>

esr(config-isis)#

CONFIG

OSPF process configuration

(CONFIG-OSPF)

router ospf <ID>

esr(config-ospf)#

CONFIG

OSPF area configuration

(CONFIG-OSPF-AREA)

area <ID>

esr(config-ospf-area)#

CONFIG-OSPF

Virtual OSPF connection configuration

(CONFIG-OSPF-VLINK)

virtual-link <ID>

esr(config-ospf-vlink)#

CONFIG-OSPF-AREA

OSPFv3 process configuration

(CONFIG-OSPFV3)

ipv6 router ospf <ID>

esr(config-ipv6-ospf)#

CONFIG

OSPFv3 area configuration

(CONFIG-OSPFV3- AREA)

area <ID>

esr(config-ipv6-ospf-area)#

CONFIG-OSPFV3

Virtual OSPFv3 connection configuration

(CONFIG-OSPFV3-VLINK)

virtual-link <ID>

esr(config-ipv6-ospf-vlink)#

CONFIG-OSPFV3-AREA

ISIS process configuration

(CONFIG-ISIS)

router isis <ID>

esr(config-isis)#

CONFIG

Key list configuration

(CONFIG-KEYCHAIN)

key-chain <KEYCHAIN>

esr(config-keychain)#

CONFIG

Key configuration

(CONFIG-KEYCHAIN-KEY)

key <ID>

esr(config-keychain-key)#

CONFIG-KEYCHAIN

MSTP parameter configuration

(CONFIG-MST)

spanning-tree mst configuration

esr(config-mst)#

CONFIG

WAN rules configuration

(CONFIG-WAN-RULE)

wan load-balance rule <ID>

esr(config-wan-rule)#

CONFIG

WAN (IPv6) rules configuration

(CONFIG-IPV6-WAN-RULE)

Ipv6 wan load-balance rule <ID>

esr(config-ipv6-wan-rule)#

CONFIG

Target list configuration

(CONFIG-TARGET-LIST)

wan load-balance target-list <NAME>

esr(config-target-list)#

CONFIG

Target list (IPv6) configuration

(CONFIG-IPV6-TARGET-LIST)

Ipv6 wan load-balance target-list <NAME>

esr(config-ipv6-target-list)#

CONFIG

Target configuration
(CONFIG-WAN-TARGET)

target <ID>

esr(config-wan-target)#

CONFIG-TARGET-LIST

Target (IPv6) configuration

(CONFIG-IPV6-WAN-TARGET)

target <ID>

esr(config-ipv6-wan-target)#

CONFIG-IPV6-TARGET-LIST

WiFi Controller configuration

(CONFIG-WIRELESS)

wireless-controller

esr(config-wireless)#

CONFIG

VRF Configuration

(CONFIG-VRF)

ip vrf <NAME>

esr(config-vrf)#

CONFIG

QoS policy configuration

(CONFIG-POLICY-MAP)

policy-map <NAME>

esr(config-policy-map)#

CONFIG

QoS class configuration

(CONFIG-CLASS-MAP)

class-map <NAME>

esr(config-class-map)#

CONFIG

Configuration of a class within the QoS policy

(CONFIG-POLICY-MAP-CLASS)

class <NAME>

esr(config-class-policy-map)#

CONFIG

Configuration of a PPP-user to authenticate the remote party

(CONFIG-PPP-USER)





ppp chap username <NAME>

esr(config-ppp-user)#




CONFIG-E1

ppp chap username <NAME>

CONFIG-MULTILINK

user <NAME>

CONFIG-CELLULAR-PROFILE

user <NAME>

CONFIG-ACCESS-PROFILE

username <NAME>

CONFIG-L2TP-SERVER

username <NAME>

CONFIG-PPTP-SERVER

Redundancy parameters configuration

(CONFIG-ARCHIVE)

archive

esr(config-archive)#

CONFIG

Netflow statistics collection server configuration

(CONFIG-NETFLOW-HOST)

netflow collector <ADDR>

esr(config-netflow-host)#

CONFIG

sFlow statistics collection server configuration

(CONFIG-SFLOW-HOST)

sflow collector <ADDR>

esr(config-sflow-host)#

CONFIG

Configuration of SNMP notification receiving server

(CONFIG-SNMP-HOST)

snmp-server host <ADDR>

esr(config-snmp-host)#

CONFIG

Changing the password after the expiration date

(CHANGE-EXPIRED-PASSWORD)

-

esr(change-expired-password)#

-

Configuration of an http request filtering profile

(CONFIG-PROFILE)

ip http profile <NAME>

esr(config-profile)

CONFIG

MPLS common parameters configuration

(CONFIG-MPLS)

mpls

esr(config-mpls)#

CONFIG

LDP common parameters configuration

(CONFIG-LDP)

ldp

esr(config-ldp)#

CONFIG

LDP IPv4 addressing configuration

(CONFIG-LDP-AF-IPV4)

address-family ipv4

esr(config-ldp-af-ipv4)#

CONFIG-LDP

LDP-unicast neighborhood configuration

(CONFIG-LDP-NEIGH)

neighbor <ADDR>

esr(config-ldp-neig)#

CONFIG-LDP

Configuration of LDP IPv4 addressing for a separate ip interface

(CONFIG-LDP-AF-IPV4-IF)

interface <IF>

esr(config-ldp-af-ipv4-if)#

CONFIG-LDP-AF-IPV4

L2-MPLS tunnel creation

(CONFIG-L2VPN)

l2vpn

esr(config-l2vpn)#

CONFIG-MPLS

L2-MPLS tunnel configuration

(CONFIG-L2VPN-EOMPLS)

vpls <NAME>

p2p <NAME>

esr(config-l2vpn-vpls)#

esr(config-l2vpn-p2p)#

CONFIG-L2VPN

PW-class (pseudo-wire pattern) configuration

(CONFIG-L2VPN-PW-CLASS)

pw-class <WORD>

esr(config-l2vpn-pw-class)#

CONFIG-L2VPN

L2-MPLS tunnel pseudo-wire parameters configuration

(CONFIG-L2VPN-PW)

pw <PW_ID> <LSR_ID> [<NEIGH_ADDR>]

esr(config-l2vpn-pw)#

CONFIG-L2VPN-EOMPLS

BGP auto-discovery and singnaling configuration

(CONFIG-AUTODISCOVERY-BGP)

autodiscovery bgp

esr(config-bgp)#

CONFIG-L2VPN-EOMPLS

IPS/IDS policy configuration

(CONFIG-IPS-POLICY)

security ips policy <NAME>

esr(config-ips-policy)#

CONFIG

IPS/IDS rule vendor configuration

(CONFIG-IPS-VENDOR)

vendor <VENDOR>

esr(config-ips-vendor)#

CONFIG-IPS-POLICY

IPS/IDS rule category configuration

(CONFIG-IPS-VENDOR-CATEGORY)

category <CATEGORY>

esr(config-ips-vendor-category)#

CONFIG-IPS-VENDOR

IPS/IDS service configuration

(CONFIG-IPS)

security ips

esr(config-ips)#

CONFIG

Configuration of auto-updating source of IPS/IDS rules distributed under a commercial license

(CONFIG-CONTENT-PROVIDER)

content-provider

esr(config-content-provider)#

CONFIG

Configuration of IPS/IDS rules autoupdate from external sources

(CONFIG-IPS-AUTO-UPGRADE)

auto-upgrade

esr(config-ips-auto-upgrade)#

CONFIG-IPS

Configuration of custom IPS/IDS rule update server

(CONFIG-IPS-UPGRADE-USER-SERVER)

user-server <WORD>

esr(config-ips-upgrade-user-server)#

CONFIG-IPS-AUTO-UPGRADE

IPS/IDS user rule category configuration

(CONFIG-IPS-CATEGORY)

security ips-category user-defined <CATEGORY_NAME>

esr(config-ips-category)#

CONFIG

User IPS/IDS rules configuration

(CONFIG-IPS-CATEGORY-RULE)

rule <ORDER>

esr(config-ips-category-rule)#

CONFIG-IPS-CATEGORY

IPS/IDS estended user rule configuration

(CONFIG-IPS-CATEGORY-RULE-ADVANCED)

rule-advanced <ORDER>

esr(config-ips-category-rule-advanced)#

CONFIG-IPS-CATEGORY

Zabbix-agent parameters configuration

(CONFIG-ZABBIX-AGENT)

zabbix-agent

esr(config-zabbix-agent)#

CONFIG

Zabbix-proxy parameters configuration

(CONFIG-ZABBIX-PROXY)

zabbix-proxy

esr(config-zabbix-proxy)#

CONFIG

Configuration of the "Antispam" service profile

CONFIG-ANTISPAM-PROFILE

security antispam profile <NAME>

esr(config-antispam-profile)#

CONFIG

Configuration of the rule for the "Antispam" service profile

CONFIG-ANTISPAM-PROFILE-RULE

rule <ORDER>

esr(config-antispam-profile-rule)#

CONFIG

Configuration of the mail domain

CONFIG-MAILSERVER-DOMAIN

mailserver domain <NAME>

esr(config-mailserver-domain)#

CONFIG

Configuration of the mail server

CONFIG-MAILSERVER

mailserver

esr(config-mailserver)#

CONFIG


1 The detailed description of commands is shown below

2 Only for ESR-21

Types and naming procedure of router interfaces

Network interfaces of various types and purposes are used for the router operation. The naming system allows you to uniquely address the interfaces by their functional purpose and location in the system. The following table contains the list of interfaces types.

Table 4 – Types and naming procedure of router interfaces

Interface type

Designation

Physical interfaces

Designation of physical interface includes its type and identifier.

The identifier of physical interfaces is as follows: <UNIT>/<SLOT>/<PORT>, where

  • <UNIT> – number of a device in a device group,
  • <SLOT> – device module number or '0' if the device does not consist of modules,
  • <PORT> – port sequence number.

1Gbps ports

gigabitethernet <UNIT>/<SLOT>/<PORT>

Designation example: gigabitethernet 1/0/12

It is permitted to use short name, for example, gi1/0/12.

10Gbps ports

tengigabitethernet <UNIT>/<SLOT>/<PORT>

Designation example: tengigabitethernet 1/0/2

It is permitted to use short name, for example, te1/0/2.

40Gbps ports

fortygigabitethernet <UNIT>/<SLOT>/<PORT>

Designation example: forygigabitethernet 1/0/2

It is permitted to use short name, for example, fo1/0/2.

Channel aggregation groups

Designation of channel aggregation group includes its type and identifier:

port-channel <CHANNEL_ID>

Designation example: port-channel 6

It is permitted to use short name, for example, po1.

Subinterfaces

Designation of sub-interface is generated from the designation of basic interface and sub-interface identifier (VLAN) separated by a dot.

Designation examples:

gigabitethernet 1/0/12.100

tengigabitethernet 1/0/2.123

port-channel 1.6

Sub-interface identifier may take values of [1..4094].

Q-in-Q interfaces

Designation of Q-in-Q interface is generated from the designation of basic interface, service VLAN identifier and user VLAN identifier separated by a dot.

Designation examples:

gigabitethernet 1/0/12.100.10

tengigabitethernet 1/0/2.45.12

port-channel 1.6.34

Service and user VLAN identifier may take values of [1..4094].

E1 interfaces

Designation of E1 interface includes its type and identifier.

E1 interfaces identifier is as follows: < UNIT>/< SLOT>/< STREAM>, where

  • <UNIT> – number of a device in a device group [1..1],
  • <SLOT> – number of device E1 module [0..12],
  • <STREAM> – E1 flow sequence number [1..1].

Designation example: e1 1/0/1

E1 channels aggregation groups

Designation of E1 channels aggregation group includes its type and interface sequence number:

multilink <CHANNEL_ID>

Designation example: multilink 3

Logical interfaces

Designation of logical interface is the interface sequence number:

Designation examples:

loopback 4

bridge 60

service-port 1

Serial interfaces

Designation of serial interface includes its type and identifier.

E1 interfaces identifier is as follows: < UNIT>/< SLOT>/< STREAM>, where

  • <UNIT> – number of a device in a device group [1..1],
  • <SLOT> – device module number or '0' if the device does not consist of modules,
  • <PORT> – port sequence number.

Designation example: serial 1/0/1

USB modems

Designation of USB modem includes its type and sequence number:

modem <MODEM-NUM>

Designation example: modem 1

FXS/FXO ports

Designation of FXS/FXO ports includes its type and sequence number:

interface voice-port <NUM>

Designation example: voice-port 1

  1. Number of interfaces of each type depends on the router model.
  2. The current firmware does not support for devices stacking. A device number in unit device group can only take the value of 1.
  3. Some commands support for simultaneous operation with the interface group. To specify the interface group, you may use a comma-separated list or specify a range of identifiers using a hyphen '-'.

Examples of interface groups specifying:

interface gigabitethernet 1/0/1, gigabitethernet 1/0/5
interface tengigabitethernet 1/0/1-2
interface fortygigabitethernet 1/0/1-2
interface gi1/0/1-3,gi1/0/7,te1/0/1,fo1/0/1
CODE

Types and naming procedure of router tunnels

Network tunnels of various types and purposes are used for the router operation. The naming system allows you to uniquely address the tunnels by their functional purpose. The following table contains the list of tunnels types.

Table 5 – Types and naming procedure of router tunnels

Tunnel type

Designation

L2TP tunnel

Designation of L2TP tunnel includes the type and sequence number of a tunnel:

l2tp <L2TP_ID>

Designation example: l2tp 1

L2TPv3 tunnel

Designation of L2TPv3 tunnel includes the type and sequence number of a tunnel:

l2tpv3 <L2TPV3_ID>

Designation example: l2tpv3 1

GRE tunnel

Designation of GRE tunnel includes the type and sequence number of a tunnel:

gre <GRE_ID>

Designation example: gre 1

GRE sub tunnel

Designation of GRE sub tunnel includes the type, sequence number of a tunnel and a sub tunnel VLAN ID:

gre <GRE_ID>.<VLAN_ID>

Designation example: gre 1.200

SoftGRE tunnel

Designation of SoftGRE tunnel includes the type and sequence number of a tunnel and, optionally, a virtual interface VLAN ID:

softgre <GRE_ID>[.<VLAN>]

Designation example: softgre 1, softgre 1.10

IPv4-over-IPv4 tunnel

Designation of IPv4-over-IPv4 tunnel includes the type and sequence number of a tunnel:

ip4ip4 <IPIP_ID>

Designation example: ip4ip4 1

IPsec tunnel

Designation of IPsec tunnel includes the type and sequence number of a tunnel:

vti <VTI_ID>

Designation example: vti 1

Logical tunnel (tunnel between VRF)

Designation of logical tunnel includes the type and sequence number of a tunnel:

lt <LT_ID>

Designation example: lt 1

PPPoE tunnel

Designation of PPPoE tunnel includes the type and sequence number of a tunnel:

pppoe <PPPoE_ID>

Designation example: pppoe 1

PPTP tunnel

Designation of PPPTP tunnel includes the type and sequence number of a tunnel:

pptp <PPTP_ID>

Designation example: pptp 1

Number of tunnels of each type depends on the router model and firmware version.