Дерево страниц

Сравнение версий

Ключ

  • Эта строка добавлена.
  • Эта строка удалена.
  • Изменено форматирование.

...

Сконфигурируем необходимые сетевые интерфейсы на каждом устройстве в сети:

Блок кода
ISP-ZERO(config)# interface gigabitethernet 1/0/1
ISP-ZERO(config-if-gi)# ip firewall disable 
ISP-ZERO(config-if-gi)# ip address 192.0.2.1/30
ISP-ZERO(config-if-gi)# do commit
ISP-ZERO(config-if-gi)# do confirm


Блок кода
ESR(config)# interface gigabitethernet 1/0/1
ESR(config-if-gi)# ip firewall disable 
ESR(config-if-gi)# description "FROM ISP-ZERO"
ESR(config-if-gi)# ip address 192.0.2.2/30
ESR(config-if-gi)# exit
ESR(config)# interface gigabitethernet 1/0/2
ESR(config-if-gi)# ip firewall disable 
ESR(config-if-gi)# ip address 192.0.2.5/30
ESR(config-if-gi)# description "TO ISP-ONE"
ESR(config-if-gi)# exit
ESR(config)# do commit
ESR(config)# do confirm


Блок кода
ISP-ONE(config)# interface gigabitethernet 1/0/1
ISP-ONE(config-if-gi)# ip firewall disable 
ISP-ONE(config-if-gi)# ip address 192.0.2.6/30
ISP-ONE(config-if-gi)# do commit
ISP-ONE(config-if-gi)# do confirm

Произведем настройку BGP:

Блок кода
ISP-ZERO(config)# ip route 10.1.1.1/32 blackhole 
ISP-ZERO(config)# ip route 0.0.0.0/0 blackhole 
ISP-ZERO(config)# route-map OUT
ISP-ZERO(config-route-map)# rule 1
ISP-ZERO(config-route-map-rule)# exit
ISP-ZERO(config-route-map)# exit
ISP-ZERO(config)# router bgp 64515 
ISP-ZERO(config-bgp)# neighbor 192.0.2.2
ISP-ZERO(config-bgp-neighbor)# remote-as 64516
ISP-ZERO(config-bgp-neighbor)# enable 
ISP-ZERO(config-bgp-neighbor)# address-family ipv4 unicast 
ISP-ZERO(config-bgp-neighbor-af)# route-map OUT out 
ISP-ZERO(config-bgp-neighbor-af)# enable 
ISP-ZERO(config-bgp-neighbor-af)# exit
ISP-ZERO(config-bgp-neighbor)# exit
ISP-ZERO(config-bgp)# enable 
ISP-ZERO(config-bgp)# address-family ipv4 unicast 
ISP-ZERO(config-bgp-af)# redistribute static 
ISP-ZERO(config-bgp-af)# do commit
ISP-ZERO(config-bgp-af)# do confirm


Блок кода
ESR(config)# route-map OUT
ESR(config-route-map)# rule 1
ESR(config-route-map-rule)# exit
ESR(config-route-map)# exit
ESR(config)# router bgp 64516
ESR(config-bgp)# neighbor 192.0.2.1
ESR(config-bgp-neighbor)# remote-as 64515
ESR(config-bgp-neighbor)# address-family ipv4 unicast 
ESR(config-bgp-neighbor-af)# enable 
ESR(config-bgp-neighbor-af)# exit
ESR(config-bgp-neighbor)# enable 
ESR(config-bgp-neighbor)# exit
ESR(config-bgp)# neighbor 192.0.2.6
ESR(config-bgp-neighbor)# remote-as 64517
ESR(config-bgp-neighbor)# address-family ipv4 unicast 
ESR(config-bgp-neighbor-af)# enable 
ESR(config-bgp-neighbor-af)# route-map OUT out 
ESR(config-bgp-neighbor-af)# exit
ESR(config-bgp-neighbor)# enable 
ESR(config-bgp-neighbor)# exit
ESR(config-bgp)# enable 
ESR(config-bgp)# do commit
ESR(config-bgp)# do confirm


Блок кода
ISP-ONE(config)# ip route 0.0.0.0/0 blackhole 
ISP-ONE(config)# route-map OUT
ISP-ONE(config-route-map)# rule 1
ISP-ONE(config-route-map-rule)# exit
ISP-ONE(config-route-map)# exit
ISP-ONE(config)# router bgp 64517
ISP-ONE(config-bgp)# neighbor 192.0.2.5
ISP-ONE(config-bgp-neighbor)# address-family ipv4 unicast 
ISP-ONE(config-bgp-neighbor-af)# route-map OUT out 
ISP-ONE(config-bgp-neighbor-af)# enable 
ISP-ONE(config-bgp-neighbor-af)# exit
ISP-ONE(config-bgp-neighbor)# remote-as 64516
ISP-ONE(config-bgp-neighbor)# enable 
ISP-ONE(config-bgp-neighbor)# exit
ISP-ONE(config-bgp)# enable 
ISP-ONE(config-bgp)# address-family ipv4 unicast 
ISP-ONE(config-bgp-af)# redistribute static 
ISP-ONE(config-bgp-af)# do commit
ISP-ONE(config-bgp-af)# do confirm


Настройка BFD

BFD (Bidirectional Forwarding Detection) — это протокол, работающий поверх других протоколов, позволяющий сократить время обнаружения проблемы до 50 мс. BFD является двусторонним протоколом, т. е. требует настройки обоих маршрутизаторов (оба маршрутизатора генерируют BFD-пакеты и отвечают друг другу).

...