|| DeviceType | Сервисные маршрутизаторы серии ESR |
|| DeviceName1 | ESR-3200|
|| DeviceType2 | Пограничный контроллер сессий |
|| DeviceName2 | ESBC-3200, vESBC |
|| DocTitleAdditional | Release notes |
|| fwversion | 1.9.0 | |
|
Версия 1.9.0
Перечень изменений в версии:
CLI:
- Расширен вывод команды show esbc trunks sip
- Расширен вывод команды show esbc statistics call (добавлены счетчики CALLS DURATION, CALLS AVERAGE DURATION, CALLS ACTIVE)
- Расширен вывод команды show esbc statistics register (добавлены счетчики REGISTERED USERS, REGISTERED CONTACTS)
- Изменены команды конфигурации common-модификаторов и sip-модификаторов
- Изменены настройки интервалов RTP/RTCP-таймаута
- Раздел конфигурирования "crypto-profle" перенесен в режим глобальной конфигурации
Работа с медиа-трафиком:
- Добавлена поддержка режима Media Offroad (передача RTP-трафика в обход ESBC)
Регистрации:
- Реализована функция "закрепления" регистрации (Refresh registration)
- Реализована функция разрегистрации абонента на регистраторе (Forced Unregistration)
- Реализована функция отправки SIP NOTIFY абоненту для его перерегистрации
- Добавлена поддержка "sip.instance" и "reg-id" (RFC5626)
- Реализована функция ограничения максимального количества регистрируемых контактов на направлении
- Реализована функция контроля максимального expires SIP-абонента
Маршрутизация/модификация SIP-сессий:
- Добавлена поддержка динамического количества:
- правил в таблице маршрутизации (общий пул правил на всю систему — 32000)
- модификаций в таблице модификации (общий пул правил на всю систему — 32000)
- Добавлена поддержка логики "И"/"ИЛИ" для:
- условий в правилах таблицы маршрутизации
- модификаций в таблице модификации
- паттернов в flood-filter
- Расширен список условий в правилах таблицы маршрутизации (использование PrefixGroup и Tags)
- Добавлена возможность настройки кода отбоя в Status-Line SIP-сообщения для правила reject в таблице маршрутизации
- Реализована функция балансировки сессий в режимах: RR — равномерное распределение и WRR — распределение по весам, в процентном соотношении
- Реализована функция ротации номеров (Cg/CdPN) из PrefixGroup (random-from-pool/round-robin) при маршрутизации вызовов
- Добавлен объект PrefixGroup (группы префиксов/номера) для гибкого отбора номеров при маршрутизации/модификации SIP-сообщений
- Добавлена поддержка установки тэгов (Tags) на SIP-сессию, для маршрутизации/модификации SIP-сообщений
- Расширен функционал common- и sip-модификаторов
- Добавлена поддержка common-модификаторов для регистраций
- Добавлена поддержка модификации RURI и Status-Line в SIP-сообщениях
- Изменена логика применения шаблонов регулярных выражений PCRE с частичного совпадения на полное совпадение для:
- условий (condition cgpn/cdpn) в правилах таблицы маршрутизации
- cause-mask в списках причин отбоя для перехода на следующее направление (cause-list)
- value-pattern в модификациях no-transit и transit таблиц маршрутизации sip
Лицензирование:
- Поддержка лицензии IPS/IDS

WEB:
- Конфигурирование
- Добавлены страницы конфигурации объектов ESBC:
- Транспорт
- Транки
- Медиаресурсы
- Абонентские интерфейсы
- Таблицы маршрутизации
- Администрирование
- Добавлена возможность отдельного удаления/скачивания ротируемых syslog-файлов
- Мониторинг
- Белый/чёрный списки вынесены на отдельные страницы
- Добавлены временные метки на всех графиках системы
vESBC:
- Добавлена поддержка компонентов VMware Tools
- Исправлена проблема с сетевыми интерфейсами в гипрвизоре Hyper-V
Прочее:
- Добавлена утилита Sngrep для визуализации и анализа SIP-трафика в реальном времени
- Добавлена возможность указания портов UDP для расшифровки SIP-трафика в команду monitor
- Добавлено логирование событий ESBC для интеграции с SIEM-системами
- Изменен функционал проксирования HTTP/HTTPS-трафика:
- Добавлена поддержка балансировки запросов между http/https-серверами
- Добавлена возможность модификации тела (body) http/https ответов
- Добавлена возможность использование "crypto-profle" для управления и проверки сертификатов https-сервера/https-клиента
Прочие изменения функционала см. в ESR-Series. Release notes. Версия 1.40 для версии 1.40.4

Версия 1.8.0
Перечень изменений в версии:
Изменение функционала:
- Добавлена регистрация транка в режиме клиента
- Реализована локальная аутентификация запросов на транке
- Реализована работа в режиме STUN-сервера
- Поддержана работа с внешними STUN-серверами
- Поддержана отправка CDR по SCP
- Поддержана отправка CDR по SFTP
- Реализована работа динамического режима транка через RADIUS
- Добавлена поддержка использования туннелирования (PPTP и L2TP over IPSec)
- Расширение возможностей маршрутизации:
- Увеличено максимальное количество объектов конфигурации
- Добавлена возможность перехода между таблицами маршрутизации
CLI:
- Мониторинг:
- Добавлен мониторинг параметров трафика (KPI) командой show esbc history
- Изменен вывод команды show esbc trunks sip
WEB:
- Мониторинг:
- Добавлен мониторинг статистики регистраций
- Добавлен мониторинг статистики подписок
- Добавлен мониторинг статистики интенсивности запросов
- Управление:
- Добавлен просмотр и управление установленными соединениями
- Добавлен сброс регистраций абонентов
- Контроль трафика:
- Расширена настройка ограничения нагрузки
- Добавлены настройки безопасности

Версия 1.7.0
Перечень изменений в версии:
Изменение функционала:
- Поддержка RFC5168
- Добавлена локальная обработка регистраций
- Поддержка RADIUS-аутентификации
- Поддержка транзита SIP-I/SIP-T
- Поддержка условий в модификаторах
- Реализовано хранение переменных SIP-модификаторов в рамках сессии
- Реализована синхронизация переменных SIP-модификаторов между плечами
- Контроль установленных сессий:
- Поддержка контроля RTCP
- Поддержка таймеров сессии (RFC4028)
Контроль трафика:
- Поддержана блокировка SIP user
- Реализовано ограничение исходящего количества вызовов в секунду
- Реализовано ограничение исходящего количества запросов в секунду
- Реализовано ограничение количества регистраций в секунду
- Реализовано ограничение количества SIP-сообщений в секунду в рамках одной сессии
- Реализовано ограничение количества подписок в секунду
- Реализовано ограничение количества активных подписок
- Реализовано ограничение количества запросов в интервал времени с зарегистрированного абонента
- Реализовано ограничение количества контактов для одного AoR
- Реализована настройка временных периодов блокировок
- Реализована защита от SIP-spoof атак:
- Добавлена проверка адреса источника сообщения
- Добавлена проверка адреса абонента
SNMP:
- Поддержан мониторинг количества регистраций в секунду
- Поддержан мониторинг количества подписок в секунду
- Поддержан мониторинг количества запросов в секунду
- Поддержка разделения входящих и исходящих метрик в мониторинге ESBC
- Добавлена возможность мониторинга черного списка AoR и User-Agent
WEB:
- Мониторинг
- Добавлена фильтрация зарегистрированных абонентов
- Администрирование
- Добавлена настройка менеджера лицензий
- Добавлена настройка логирования в файл
CLI:
- Мониторинг
- Расширен вывод чёрного списка командой show esbc black-list
- Реализован вывод черного списка SIP user
- Реализован мониторинг SIP Call Flow Diagram
- Управление
- Расширена команда для удаления из чёрного списка
- Добавлена возможность удаления заблокированного SIP user
- Добавлена возможность удаления по паттернам заблокированных AoR и User-Agent

Версия 1.6.0
Перечень изменений в версии:
Изменения функционала:
- Поддержка Public-IP
- Добавлен динамический режим для транков
- Поддержка QoS (маркировка качества обслуживания) для различных видов трафика
- Реализована маршрутизация по произвольному заголовку SIP
- Реализована запись и отправка CDR
- Реализована настройка параметров TLS для использования в SIP-транспорте и медиапрофиле
Контроль трафика:
- Расширена защита от SIP-флуда
- Расширен список причин блокировки
- Поддержана блокировка по AOR
- Поддержана блокировка по User-Agent
- Поддержана блокировка запросов, приходящих вне транка/абонентского интерфейса
SNMP:
- Поддержан мониторинг ESBC
- Поддержана отправка SNMP-трапов об авариях ESBC
WEB:
- Мониторинг
- Реализован мониторинг белого списка
- Реализован мониторинг списка заблокированных IP-адресов
- Реализован мониторинг транков
- Реализован список зарегистрированных абонентов
- Реализовано отображение статистики вызовов
- Конфигурация
- Добавлена страница с общими настройками ESBC (изменение количества модулей, ограничение входящей связи, включение статистики)
- Администрирование
- Поддержана работа с архивными файлами
- Добавлено сравнение конфигураций
CLI:
- Реализована команда snmp-server enable traps esbc для отправки SNMP-трапов об авариях ESBC
- Мониторинг
- Расширен вывод чёрного списка командой show esbc black-list
- Реализован вывод черного списка AOR
- Реализован вывод чёрного списка User-Agent
- Переработан вывод статистики командой show esbc statistics
- Добавлены исходящие метрики в статистике вызовов
- Добавлена статистика по регистрациям
- Добавлена статистика по подпискам
- Добавлена статистика по запросам в секунду
- Реализован вывод списка установленных соединений командой show esbc active calls
- Управление
- Расширена команда для удаления из чёрного списка
- Добавлена возможность удаления заблокированного AOR
- Добавлена возможность удаления заблокированного User-Agent
- Реализована команда для разрушения установленных соединений
- Реализована команда для сброса абонентских регистраций
Версия 1.5.0
Перечень изменений в версии:
Изменения функционала:
- Поддержка DHCP в конфигурации SIP-транспортов и медиаресурсов
- Добавлена поддержка соединения за NAT для абонентов (CRLF)
- Реализована опциональная обработка перенаправления вызова
- Поддержка WebRTC (+ ICE)
Контроль трафика:
- Реализовано ограничение количества одновременных сессий
- Реализовано ограничение количества вызовов в секунду
- Реализовано ограничение количества запросов в секунду
Лицензирование:
- Поддержана работа с Offline ELM для vESBC
- Поддержаны файловые лицензии для ESBC-3200
- Добавлена лицензия ESBC-LIMIT-MAX-CALLS для ограничения максимального количества одновременных сессий
- Добавлена лицензия ESBC-LIMIT-MAX-CPS для ограничения максимального количества вызовов в секунду
WEB:
- Мониторинг
- Реализовано отображение графика загрузки CPU
- Администрирование
- Реализовано обновление ПО и управление загруженными образами
- Реализован мониторинг лицензий для vESBC
- Реализована загрузка и мониторинг лицензий для ESBC-3200
- Реализована загрузка и управление файлами конфигурации
- Реализованы общие настройки логирования
- Реализована настройка удалённых syslog-серверов
CLI:
- Реализована команда clear esbc black-list для удаления адресов из чёрного списка
- Реализована команда statistics call для включения статистики вызовов
- Мониторинг
- Реализован вывод чёрного списка
- Реализован вывод белого списка
- Реализован мониторинг состояния транков
- Реализован вывод списка зарегистрированных абонентов
- Реализован вывод статистики вызовов (глобально и по направлениям)

Версия 1.4.0
Перечень изменений в версии:
Изменения функционала:
- Поддержка модификации CgPN, CdPN
- Поддержка режима nat-comedia для транков
- Добавлен режим преобразования атрибутов CDP "sendonly/recvonly" в "sendrecv" для режима nat-comedia
- Поддержка модификации любых заголовков SIP, использование переменных в модификаторах, модификатор типа copy
- Поддержка транскодинга

Версия 1.3.0
Перечень изменений в версии:
Поддержано резервирование 1+1 на ESR-3200

Версия 1.2.0
Перечень изменений в версии:
Добавлена возможность запуска на ESR-3200.
Изменения функционала:
- Поддержка подписок BLF
- Поддержка аутентификации SUBSCRIBE
- Поддержка SRTP (SDES, DTLS-SRTP)
- Настройка разрешённых типов media
- Поддержка RTP-timeout
- Проверка доступности SIP-транков с помощью OPTIONS
- Добавлен список ответов для динамической маршрутизации
- Динамическое ограничение количества доступных модулей
- Поддержка answer SDP в ACK
- Хранение и восстановление записей о зарегистрированных абонентах
- Поддержка TLS транспорта
- Добавлено опциональное разделение SIP-транков по домену
CLI:
- Реализована возможность конфигурирования SIP-профилей
- Реализована возможность конфигурирования медиапрофилей
- Реализована возможность конфигурирования списка причин отбоя
- Добавлены команды no esbc для сброса конфигурации ESBC и reload esbc force для перезапуска ПО ESBC
- Добавлены команды ip http server и ip https server для включения Web-сервера
WEB:
- Добавлен мониторинг общих системных параметров
Версия 1.1.1
Перечень изменений в версии:
Поддерживаемые RFC:
- RFC-1889 (RTP)
- RFC-2833 (Telephone Event)
- RFC-3261
- RFC-3264 (Offer/Answer)
- RFC-3311 (Update Method)
- RFC-3515 (Refer Method)
- RFC-4566 (SDP)
Изменения функционала:
- Поддержка B2BUA peering
- Поддержка протокола сигнализации SIP
- Трансляция публичных адресов
- Анализ и верификация SDP
- Поддержка UDP-, TCP-транспортов
- Проксирование RTP- и RTCP-трафика
- Работа с абонентами за NAT
- Модификация SIP-заголовков с помощью регулярных выражений
- Добавление/удаление пользовательских SIP-заголовков
- Маршрутизация на группу направлений с поддержкой логики балансировки
- Поддержка перемаршрутизации при неудачном вызове
- Проксирование T38 UDPTL-трафика
- Добавлена защита от DoS
- Добавлена защита от VoIP-атак