Page tree
Skip to end of metadata
Go to start of metadata

Как и LAG, виртуальные LAG позволяют объединить одну или несколько Ethernet-линий для  увеличения скорости и обеспечения отказоустойчивости. MLAG так же известна как VPC (Virtual port-channel). При обычном LAG агрегированные линии должны быть на одном физическом устройстве, в случае же с VPC агрегированные линии находятся на разных физических устройствах.
Функция VPC позволяет соединить два физических устройства в одно виртуальное.

Один из коммутаторов имеет роль VPC-primary, второй VPC-secondary


Настройка MLAG на коммутаторах:

Основной линк для работы VPC на MES5448/7048 - peer-detection (не путать с peer-detection на MES23xx/33xx/53xx/5400-xx), в качестве такого линка может быть назначен только интерфейс LAG. В данном примере это 1/0/47 порты, добавленные в LAG 48. 

Дополнительный линк - peer-keepalive, необходим для проверки "жив ли второй коммутатор". Необходим для ситуации, когда упал основной линк, но коммутаторы при этом работают нормально. При настроенном peer-keepalive в случае падения основного линка secondary-коммутатор переводит все порты, состоящие в VPC группах, в состояние errdisable.

Трафик при этом будет ходить через primary-коммутатор. В качестве peer-keepalive необходимо использовать отдельный линк в режиме L3.  В данном примере это линк 1/0/48. Возможно использование OOB-портов.


SW1:


vlan database
vlan 100
vlan routing 1 1
vlan routing 100 3
exit

configure

interface 1/0/1
addport lag 1
exit
interface 1/0/2
addport lag 2
exit
interface 1/0/47
addport lag 48
exit
!
interface 1/0/1
no shutdown
exit
!
interface 1/0/2
no shutdown
exit
!

interface 1/0/48
no shutdown

routing

ip address 10.5.0.1 255.255.255.0
exit

!
interface 1/0/47
no shutdown
exit
!
interface lag 1
no port-channel static
switchport mode trunk
vpc 1
exit
!
interface lag 2
switchport mode trunk
vpc 2
exit
!
interface lag 48
switchport mode trunk
vpc peer-link
exit
!
interface vlan 1
routing
ip address 10.1.0.21 255.255.255.0
exit
!
feature vpc
vpc domain 1
peer-keepalive enable
peer-keepalive destination 10.5.0.2 source 10.5.0.1
peer detection enable
exit
exit


SW2


vlan database
vlan 100
vlan routing 1 1
vlan routing 100 3
exit

configure
interface 1/0/1
addport lag 1
exit
interface 1/0/2
addport lag 2
exit
interface 1/0/47
addport lag 48
exit
!
interface 1/0/1
no shutdown
exit
!
interface 1/0/2
no shutdown
exit
!

interface 1/0/48
no shutdown

routing

ip address 10.5.0.2 255.255.255.0
exit

!
interface 1/0/47
no shutdown
exit
!
interface lag 1
no port-channel static
switchport mode trunk
vpc 1
exit
!
interface lag 2
switchport mode trunk
vpc 2
exit
!
interface lag 48
switchport mode trunk
vpc peer-link
exit
!
interface vlan 1
routing
ip address 10.1.0.22 255.255.255.0
exit
!
feature vpc
vpc domain 1
peer-keepalive enable
peer-keepalive destination 10.5.0.1 source 10.5.0.2
peer detection enable
exit
exit


На коммутаторах SW3 и SW4 настроить порты и Port-Channel. Разрешить 100 VLAN.


Примечания:

1) В случае падения Peer-keepalive линка не происходит никакой реакции.

2) Номер VPC домена должен совпадать на обоих коммутаторах, при этом каждый коммутатор может принадлежать только к одному VPC домену. Сам номер VPС домена используется для генерации system-mac-VPC, который является общим для двух коммутаторов.

Для изменения system-mac используется команда:

console (Config)# vpc domain 1
console (Config-Vpc 1)# system-mac XX:XX:XX:XX:XX:XX

3) Primary коммутатор рассылает BPDU (при этом не обязательно чтобы коммутатор был STP Root).

4) При настройке VPC на одноранговых коммутаторах должна быть одинаковая версия программного обеспечения.

5) Для peer-keepalive сообщений не рекомендуется использовать основной линк VPC (нет смысла)


Диагностические команды:

show vpc brief

show vpc role

show vpc peer-keepalive

  • No labels