Page tree
Skip to end of metadata
Go to start of metadata

В качестве примера, настроим соседство OSPF между коммутаторами MES3124 (версия 2.5.47) и MES3324 (версия 4.0.9).


1) Создаем interface vlan для создания соседства

console(config)# interface vlan 10

console(config-if)# ip address 10.10.10.5 255.255.255.252

console(config-if)# exit

2) Настройки в режиме глобальной конфигурации

console(config)# router ospf 1

console(router_ospf_process)# network 10.10.10.5 area 4.4.4.4

console(router_ospf_process)# router-id 5.5.5.5

console(router_ospf_process)# exit


 Контроль работы протокола

Просмотр  ospf соседей  - sh ip ospf neighbor

Просмотр таблицы LSDB - show ip ospf database

Просмотр состяния ospf -  sh ip ospf


Настройка параметров ospf аутентификации

1) Настраиваем ключ для аутентификации

console(config)# key chain TEST_KEYCHAIN

(config-keychain)# key 1

(config-keychain-key)# key-string test

(config-keychain-key)# exit

(config-keychain)# exit


2) Добавляем ключ к аутентификации md5 по ospf

console(config)# interface ip 10.10.10.5

console(config-ip)# ip ospf authentication message-digest

console(config-ip)# ip ospf authentication message-digest

console(config-ip)# ip ospf authentication key-chain TEST_KEYCHAIN

console(config-ip)# ip ospf authentication-key 1

console(config-ip)# ip ospf cost 1

console(config-ip)# exit


Для перевода номера области из числового вида в формат записи ip address нужно число перевести в двоичный вид. После этого записать его в строку и разделить на 4 части по 8 бит.